[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r17326 - trunk/subversion/tests/clients/cmdline

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2005-11-14 13:06:54 CET

> >>> Log:
> >>> Unmark test for issue #2306 XFAIL.
> >>>
> >>>
> >> the log message should mention the file and symbol that was changed.
> >>
> >
> > It's a one line change. I *really* think that'd make the log message
> > more complex than necessary. I'm sorry I think this is one of those
> > cases where strictness is not a gain.
> >
> It's a one-line change, but it still means one has ti either run "svn
> log -v" or "svn diff" to see where the change was made. You can still
> write a one-line log message that conforms to our coding style.

Also, isn't that exactly what svn log -v is for?!

It's always been a project policy to be strict on the rules, but in a
functional way. Having the file name and especially the fact that it
happened to the symbol test_list doesn't add any *usefull* information
to the message and reduces its readability. That's why I think
applying the rules as strictly as this is non-functional and was
applying project policy from a functional perspective. I'd like to
keep on doing so.

> Please fix it.

I did - before sending the mail, but still don't agree: we don't do
things "because it's the rules", we invent the rules "because it's the
best way we know how to do it". But sometimes, the generally-best-way
just isn't the best way.


Received on Mon Nov 14 13:08:17 2005

This is an archived mail posted to the Subversion Dev mailing list.