On Mar 23, 2005, at 7:21 PM, Julian Foad wrote:
> Here is a quick review of the public APIs marked "@since New in 1.2"
> in r13616, and of the doc strings of the APIs deprecated by them.
Thanks for this fantastic review, Julian. What a great cleanup this
will be. As you can see, we committed most of this stuff as giant
to-do list, so we can start picking stuff off.
What I'm replying to here are the (very few) things that we're *not*
putting on the list.
> Enhancement: Ought to use "depth" instead of "recurse".
Our feeling is that this is out of scope for 1.2. There's already an
issue filed on this, and it needs to be a carefully-constructed,
widespread API change. There's certain nothing forcing us to do this
*now*. (Maybe we should assign the issue to 1.3?)
> Enhancement: Ought to use "depth" instead of "descend" or
> Maybe "descend" and "recursive" ought to be renamed to "recurse" for
...however, the word 'descend' should definitely be excised now.
That's quick and easy. Then, in the future, we merely need to go
through all the mentions of 'recurs(ive)" and "nonrecursive" and
replace them with a real depth-indication system (enum?).
> Enhancement: Ought to update all targets from the same repository to
> same revision.
Again, this is already a filed issue with a long and painful history,
definitely not easy to fix. I don't think svn 1.2 should block on it.
> I'm not terribly happy with this. I don't think it makes clear what
> "server mode" is and why.
Hm, this API seems to have vanished...?
> Someone raised a concern about whether these belong in svn_error.h.
What exactly is the complaint here? These are now macros, and all
three RA implementations need to share them. Should they go somewhere
> Why has the error number changed? Isn't that an ABI violation if we
> are now returning a different number for semantically the same error?
> Shouldn't the new name be added, equal to the old name, and the
> default message be changed to
> the new one?
Hm, considering we're getting ready to revert kfogel's repos-bumping
change, I suspect we'll have a nice fresh chance to revisit this.
> Contradiction: "@a lock->owner must be filled in with an
> authenticated username. If not, ...". Change "must" to "may".
This API is now gone.
To unsubscribe, e-mail: firstname.lastname@example.org
For additional commands, e-mail: email@example.com
Received on Mon Mar 28 23:06:38 2005