[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "force" option in APIs

From: Peter N. Lundblad <peter_at_famlundblad.se>
Date: 2005-03-23 14:31:43 CET

On Wed, 23 Mar 2005, Julian Foad wrote:

> The "force" option thus has no place in an API unless the API is intended to
> directly implement one particular UI, which ours are not. If an API wants to

This is what I have been thinking also, so I naturally agree.

> provide a way to disable the checks for validity of "svn:*" properties, then
> the option should be called "disable_svn_property_checks", etc. To also allow
> deletion of a nonexistent property, add another option,
> "allow_delete_nonexistent_property", etc.
Another alternative is to have an callback for asking those questions.
This is useful, since a GUI could choose to ask for each individual path
(i.e. lock is currently owned by albert, steal it?).

If we choose this strategy, the CLI could just answer yes if the force
option was specified.

> Also (many?) other APIs, especially any that are new in 1.2.
Maybe this isn't the right time in the 1.2 dev cycle to push such a
change, thoug.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Mar 23 14:28:40 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.