[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r11400 - trunk/subversion/libsvn_delta

From: <kfogel_at_collab.net>
Date: 2004-10-14 19:29:42 CEST

"C. Michael Pilato" <cmpilato@collab.net> writes:
> I think that when an environment is lacking a macro generally
> available (or expected), simply adding that macro (with its expected
> name) is a useful aid for developers. But if we insist on writing our
> own macro, and if there exists a problem such that our definition or
> undefinition of a macro can interfere with other macros of the same
> name elsewhere, then I'd prefer we either use a macro name that is in
> the SVN_ namespace. Those are my only reasons.

If we were going to move it out to a .h file, I'd want an SVN_ prefix.
Inline in a C function as it is right now, though, TMP_ feels better
to me. I wouldn't complain it if you change it, though.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Oct 14 21:19:29 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.