[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] SVN_REVFMT_T -> svn_revnum_to_cstring

From: Ben Reser <ben_at_reser.org>
Date: 2004-05-12 08:52:16 CEST

On Mon, May 10, 2004 at 01:50:56PM -0500, kfogel@collab.net wrote:
> It would be a huge change, but if it saves us future trouble, it's
> worth it.
> I think it's fine. It's not a portability issue: *we* decide what
> svn_revnum_t is, and if we say it's a long int, then it's a long int.
> And it would be more readable / easier to work with, in the long run.

It'd be nice if xgettext could expand string constants... Because it
would make all this moot. But then I'd guess it'd need to become a C
Pre Processor and we all know that isn't desireable. :)

Ben Reser <ben@reser.org>
"Conscience is the inner voice which warns us somebody may be looking."
- H.L. Mencken
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed May 12 08:52:32 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.