[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] SVN_REVFMT_T -> svn_revnum_to_cstring

From: <kfogel_at_collab.net>
Date: 2004-05-10 20:50:56 CEST

"Peter N. Lundblad" <lundblad@softhome.net> writes:
> That would also be a huge change:-) Except for the addition of a pool
> argument in some internal functions, the same places need to be updated.
> I'll do it this way instead if you prefer it. I'll wait a few days to give
> more developers a chance to have an opinion.

It would be a huge change, but if it saves us future trouble, it's
worth it.

I think it's fine. It's not a portability issue: *we* decide what
svn_revnum_t is, and if we say it's a long int, then it's a long int.
And it would be more readable / easier to work with, in the long run.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon May 10 22:07:30 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.