[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] SVN_REVFMT_T -> svn_revnum_to_cstring

From: Peter N. Lundblad <lundblad_at_softhome.net>
Date: 2004-05-12 10:19:38 CEST

On Tue, 11 May 2004, Ben Reser wrote:

> On Mon, May 10, 2004 at 01:50:56PM -0500, kfogel@collab.net wrote:
> > It would be a huge change, but if it saves us future trouble, it's
> > worth it.
> >
> > I think it's fine. It's not a portability issue: *we* decide what
> > svn_revnum_t is, and if we say it's a long int, then it's a long int.
> > And it would be more readable / easier to work with, in the long run.
> It'd be nice if xgettext could expand string constants... Because it
> would make all this moot. But then I'd guess it'd need to become a C

If we don't revert r9691, it is moot anyway. The problem with expanding
string constant macros is that the translation will be platform dependent
if the string constant is it. So you have to modify the gettext runtime as
well. As I pointed out earlier, GNU gettext already did that, but only for
the C99 <inttypes.h> macros.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed May 12 10:10:19 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.