[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Issue #1075

From: <cmpilato_at_collab.net>
Date: 2003-04-28 17:51:33 CEST

Brian Denny <brian@briandenny.net> writes:

> Okay, here's a patch for #1075, sans regression tests so far, but
> enough that some kind soul (Ben? Mike?) could look it over. :)

Patch looks pretty good.

My only concern is how svn_wc__do_update_cleanup() plugs into
svn_wc_add(). If I understand the code correctly, your new goodness
will get called any time svn_wc_add is called on a directory with
copyfrom args. I don't think we want that behavior at all.

Of course, that revealed another annoyance, namely that here we have a
function called svn_wc__do_update_cleanup() that's being used for
other purposes than updates.

So I'd suggested two things:

  - a flag to this function stating whether or not to do this
    missing-item check, true in all cases except the svn_wc_add call, and
  - a new name for the function altogether that matches its
    functionality in all its use-cases. :-)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Apr 28 17:55:50 2003

This is an archived mail posted to the Subversion Dev mailing list.