[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Problems building 0.16 under OSX 10.2.2

From: Seth Landsman <seth_at_boondock.cs.brandeis.edu>
Date: 2002-12-04 21:26:07 CET

Folks,
        I've having issues building subversion 0.16 under OSX. I'm
hoping someone can help me out.

        The machine a TiBook running 10.2.2. Everything on it is pretty
standard. I have fink install in /sw, but that shouldn't affect
anything (I think).

        To build, I ran:

./configure
make

        from the 0.16 tarball off of subversion.tigris.org

        The errors I get are:

make[2]: Nothing to be done for `all'.

  Compilation complete. Run 'make install' (as root?) to install neon.

------ completed all in neon
cd subversion/clients/cmdline && /bin/sh
/Users/seth/PROJECTS/svn/subversion-r3987/libtool --silent --mode=link
gcc -g -O2 -DNEON_ZLIB
-L/Users/seth/PROJECTS/svn/subversion-r3987/apr-util/xml/expat/lib
-rpath /usr/local/lib -o svn add-cmd.o cat-cmd.o checkout-cmd.o
cleanup-cmd.o commit-cmd.o copy-cmd.o delete-cmd.o diff-cmd.o
export-cmd.o feedback.o help-cmd.o import-cmd.o info-cmd.o log-cmd.o
ls-cmd.o main.o merge-cmd.o mkdir-cmd.o move-cmd.o prompt.o
propdel-cmd.o propedit-cmd.o propget-cmd.o proplist-cmd.o props.o
propset-cmd.o resolve-cmd.o revert-cmd.o status-cmd.o status.o
switch-cmd.o update-cmd.o util.o
../../../subversion/libsvn_client/libsvn_client-1.la
../../../subversion/libsvn_wc/libsvn_wc-1.la
../../../subversion/libsvn_ra/libsvn_ra-1.la
../../../subversion/libsvn_delta/libsvn_delta-1.la
../../../subversion/libsvn_subr/libsvn_subr-1.la
/Users/seth/PROJECTS/svn/subversion-r3987/apr-util/libaprutil-0.la
/Users/seth/PROJECTS/svn/subversion-r3987/apr-util/xml/expat/lib/libexpat.la
/Users/seth/PROJECTS/svn/subversion-r3987/apr/libapr-0.la -lm
/Users/seth/PROJECTS/svn/subversion-r3987/neon/src/libneon.la
-L/usr/local/lib -lz
ld: archive:
/Users/seth/PROJECTS/svn/subversion-r3987/apr-util/.libs/libaprutil-0.a
has no table of contents, add one with ranlib(1) (can't load from it)
ld: archive:
/Users/seth/PROJECTS/svn/subversion-r3987/apr/.libs/libapr-0.a has no
table of contents, add one with ranlib(1) (can't load from it)
make: *** [subversion/clients/cmdline/svn] Error 1

Any ideas?

Thanks,
 Seth

-- 
it is by will alone I set my mind in motion
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Dec 4 21:31:21 2002

This is an archived mail posted to the Subversion Dev mailing list.