I would like our API to be consistent about how it refers to C-style
(null-terminated) strings. Right now some older functions use
"cstring" and some newer functions use "nts" (a lot fewer of them
after I simplified the svn_path interfaces). A summary:
nts cstring
--- -------
svn_xml_escape_nts svn_wc_translate_cstring
svn_xml_unescape_nts svn_cstring_split
svn_time_to_nts svn_cstring_split_append
svn_time_from_nts svn_utf_cstring_to_utf8_stringbuf
svn_time_to_human_nts svn_utf_cstring_to_utf8
svn_utf_cstring_from_utf8
svn_utf_cstring_from_utf8_fuzzy
svn_utf_cstring_from_utf8_stringbuf
svn_utf_cstring_from_utf8_string
I happen to find "cstring" a more readable convention (it wasn't at
all clear to me at first that "nts" stood for "null-terminated string"
and not some ISO time concept, when I first saw svn_time_to_nts). Are
there any -1s on renaming the last five _nts functions to _cstring
functions?
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 20 11:37:53 2002