[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 3151 - clients/rapidsvn/trunk/src/tests/svncpp clients/rapidsvn/trunk/src/svncpp

From: Nuutti Kotivuori <naked_at_iki.fi>
Date: 2002-09-11 14:58:19 CEST

brane@xbc.nu wrote:
> Alexander Mueller wrote:
>> Branko ╚ibej wrote:
>>> Alexander Mueller wrote:
>>>> Doesnt look bad as well. For me, "doExport" or "doSwitch" is
>>>> fine. Its a matter of taste.
>>> Or just Export and Switch; C++ is case-sensitive, right?
>> Hm. Personally, I dont like case mixing.
>> -1
> Strange, you said you were satisfied with doExport and doSwitch,
> which is mixing case in the extreme. :-) And the RapidSVN classes
> seem to be capitalized.
> Anyway, if I had a vote, I'd suggest do_something, with something_
> taking second place.

You are talking apples and oranges. Alex means that he doesn't like
inconsistent case, brane is saying things about having mixed case at

It's all about the naming conventions - it's either:

1. thisMethod()
2. ThisMethod()
3. this_method()

for the whole of the interface - and from that results either:

1. doExport()
2. Export()
3. do_export()


1. export_()
2. Export()
3. export_()

with respective conventions. Ofcourse there's other choices as well,
but the choice of the naming convention as a whole should determine if
Export is inconsistent or not regarding the other functions.

-- Naked

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Sep 11 15:00:10 2002

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.