[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: libtool 1.4 problem

From: Karl Fogel <kfogel_at_collab.net>
Date: 2001-07-02 23:11:49 CEST

Joe Orton <jorton@btconnect.com> writes:
> IIRC the .libs thing was to get inter-library dependencies working:
> something that libtool 1.3 doesn't support but 1.4 does (I think in
> theory the build can be simplified further by requiring 1.4, not that I
> am advocating that position since I'm hand-waving)

I think requiring 1.4 is fine, as long as we're sure we can build
Subversion under it. Jon and Ben have confirmed that we can, using
Jon's patch (is that right, guys?).

If so, let's apply the patch, but also tweak autogen.sh or something
to look for libtool 1.4 and complain (with URL) if it can't find it,
so people are led along the upgrade path conveniently.

Ben points out that APR does check for a libtool 1.3.3 or newer, which
both 1.3.5 and 1.4 will satisfy. However, Jon's patch included a
patch to APR's install.sh. Is that part of the patch *required* for
us to switch Subversion to 1.4, or can we just apply the Subversion
portions of the patch and take up the APR portion with the APR dev
list separately?

-Karl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:32 2006

This is an archived mail posted to the Subversion Dev mailing list.