[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

libtool 1.4 problem

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2001-07-02 18:19:09 CEST

A friend of ours has discovered a compatibility problem between
the latest libtool (1.4) and our build system.

I was able to reproduce the problem myself. Here's what I did:

   * virgin RedHat 7.0 system
   * built & installed db3.2.9 and libtool 1.4
   * checked out subversion, apr, neon.
   * ./autogen && ./configure --enable-maintainer-mode --disable-shared

When I run `make`, I get errors linking the svn binary:

=======================================================================
cd subversion/clients/cmdline && /bin/sh /home/sussman/projects/subversion/libtool --silent --mode=link gcc -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations -pthread -Wpointer-arith -Wwrite-strings -Wshadow -DSVN_DEBUG -DAP_DEBUG -I./subversion/include -I. -I./apr/include -I./neon/src -I./expat-lite -I/usr/local/BerkeleyDB.3.2/include -rpath /usr/local/lib -o svn add-cmd.o checkout-cmd.o commit-cmd.o delete-cmd.o diff-cmd.o diff.o feedback.o help-cmd.o import-cmd.o main.o propget-cmd.o proplist-cmd.o props.o propset-cmd.o status-cmd.o status.o trace-commit.o trace-update.o update-cmd.o util.o ../../../subversion/libsvn_client/libsvn_client.la ../../../subversion/libsvn_wc/libsvn_wc.la ../../../subversion/libsvn_ra/libsvn_ra.la ../../../subversion/libsvn_delta/libsvn_delta.la ../../../subversion/libsvn_subr/libsvn_subr.la /home/sussman/projects/subversion/apr/libapr.la /home/su!
 ssman/projects/subversion/apr/shmem/unix/mm/libmm.la ../../../expat-lite/libexpat.la -lm -lcrypt -lnsl -ldl
gcc: /home/sussman/projects/subversion/subversion/libsvn_ra_dav/.libs/.libs/libsvn_ra_dav.a: No such file or directory
gcc: /home/sussman/projects/subversion/neon/src/.libs/.libs/libneon.a: No such file or directory
gcc: /home/sussman/projects/subversion/subversion/libsvn_ra_local/.libs/.libs/libsvn_ra_local.a: No such file or directory
gcc: /home/sussman/projects/subversion/subversion/libsvn_delta/.libs/.libs/libsvn_delta.a: No such file or directory
gcc: /home/sussman/projects/subversion/subversion/libsvn_subr/.libs/.libs/libsvn_subr.a: No such file or directory
gcc: /home/sussman/projects/subversion/subversion/libsvn_repos/.libs/.libs/libsvn_repos.a: No such file or directory
gcc: /home/sussman/projects/subversion/subversion/libsvn_fs/.libs/.libs/libsvn_fs.a: No such file or directory
make: *** [subversion/clients/cmdline/svn] Error 1
=======================================================================

Our friend theorizes that the new libtool is somehow confused by our
non-recursive make system. I don't know enough to diagnose. Anyone
have a definitive analysis of the problem?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:32 2006

This is an archived mail posted to the Subversion Dev mailing list.