[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: CVS update: subversion/subversion/include svn_delta.h

From: Karl Fogel <kfogel_at_galois.collab.net>
Date: 2000-08-16 21:44:41 CEST

Greg Stein <gstein@lyra.org> writes:
> I'd highly recommend using a typedef such as svn_vernum_t to represent this.
> That gives you one good feature (semantics, leading to readability, type
> checking, maintenance, understandability) and one minor feature (ability to
> change the type if necessary; e.g. make it unsigned).

That seems like a good idea.

We had a recent phone conversation with JimB where we tentatively
decided not to make special types that just mirror native C types, but
I think the reasons for that decision don't apply so well in this
case. Plus, it's always easier to change back from custom type to
native type, than the other direction. :-)

> And note that "long int" is a bit weird. Nowadays it is usually just "long"

"Well, back in *my* day..."

Received on Sat Oct 21 14:36:06 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.