[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: CVS update: subversion/subversion/include svn_delta.h

From: Greg Stein <gstein_at_lyra.org>
Date: 2000-08-16 23:45:27 CEST

On Wed, Aug 16, 2000 at 09:35:27PM -0000, kfogel@tigris.org wrote:
> User: kfogel
> Date: 00/08/16 14:35:27
> Modified: subversion/include svn_delta.h
> Log:
> Use `long int' instead of the non-existent `svn_version_t'.

I'd highly recommend using a typedef such as svn_vernum_t to represent this.
That gives you one good feature (semantics, leading to readability, type
checking, maintenance, understandability) and one minor feature (ability to
change the type if necessary; e.g. make it unsigned).

And note that "long int" is a bit weird. Nowadays it is usually just "long"


Greg Stein, http://www.lyra.org/
Received on Sat Oct 21 14:36:06 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.