[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: CVS update: subversion/subversion/include svn_delta.h

From: Greg Stein <gstein_at_lyra.org>
Date: 2000-08-17 00:14:42 CEST

On Wed, Aug 16, 2000 at 02:44:41PM -0500, Karl Fogel wrote:
> Greg Stein <gstein@lyra.org> writes:
> > I'd highly recommend using a typedef such as svn_vernum_t to represent this.
> > That gives you one good feature (semantics, leading to readability, type
> > checking, maintenance, understandability) and one minor feature (ability to
> > change the type if necessary; e.g. make it unsigned).
> That seems like a good idea.
> We had a recent phone conversation with JimB where we tentatively
> decided not to make special types that just mirror native C types, but

I would agree that making something like "svn_long_t" would be a bad idea :-)
In all other cases, I actually think it makes a lot of sense because of the
semantic value-add.

> I think the reasons for that decision don't apply so well in this
> case.

Yup. A type name lends semantics to the code where a "long" or "char" fail.

> Plus, it's always easier to change back from custom type to
> native type, than the other direction. :-)

Good point :-)


Greg Stein, http://www.lyra.org/
Received on Sat Oct 21 14:36:06 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.