[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN 1.8.0 segmentation fault behind proxy on Mac OS X

From: Daniel Shahaf <danielsh_at_elego.de>
Date: Tue, 2 Jul 2013 16:51:00 +0300

Lieven Govaerts wrote on Tue, Jul 02, 2013 at 12:13:55 +0200:
> Hi Guillaume,
>
>
> thanks for the report.
>
> On Tue, Jul 2, 2013 at 11:56 AM, Guillaume Lasnier
> <guillaume.lasnier_at_hybris.com> wrote:
> > Hi,
> > Please find below the content of the crash log:
> >
> > Process: svn [29901]
> > Path: /usr/local/Cellar/subversion/1.8.0/bin/svn
> > Identifier: svn
> > Version: 0
> > Code Type: X86-64 (Native)
> > Parent Process: bash [47372]
> > User ID: 1487951899
> >
> > Date/Time: 2013-07-02 11:19:42.732 +0200
> > OS Version: Mac OS X 10.8.4 (12E55)
> > Report Version: 10
> > Sleep/Wake UUID: C3009E0E-2CB9-4556-AAD0-09ECAC6E2DFA
> >
> > Interval Since Last Report: 41279 sec
> > Crashes Since Last Report: 1
> > Per-App Crashes Since Last Report: 1
> > Anonymous UUID: 79280656-DCE2-27AC-92A0-FF685CC020F5
> >
> > Crashed Thread: 0 Dispatch queue: com.apple.main-thread
> >
> > Exception Type: EXC_BAD_ACCESS (SIGSEGV)
> > Exception Codes: KERN_INVALID_ADDRESS at 0x00000000000001b0
> >
> > VM Regions Near 0x1b0:
> > -->
> > __TEXT 000000010816e000-0000000108198000 [ 168K]
> > r-x/rwx SM=COW /usr/local/Cellar/subversion/1.8.0/bin/svn
> >
> > Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
> > 0 libsvn_ra_serf-1.0.dylib 0x000000010837c7dd
> > svn_ra_serf__credentials_callback + 77
>
> Based on this line I think your connecting to a repository on a https
> server using a http proxy. The setup of the ssl tunnel when the proxy
> requires authentication is broken in serf 1.2.1 used in svn 1.8.1.
>
> You can find more details here:
> http://svn.haxx.se/dev/archive-2013-06/0490.shtml
>
> The issue is fixed in serf and will be included in the next release.
>

To clarify, Lieven means the next serf release --- that is, serf 1.2.2
and/or serf 1.3.0. Upgrading Subversion to 1.8.1 would not be required
if you can upgrade serf itself independently.

(Unfortunately, 'svn --version --verbose' doesn't state the version of
serf svn uses.)

Daniel

> Lieven
Received on 2013-07-02 15:53:36 CEST

This is an archived mail posted to the Subversion Users mailing list.