[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Tigris binary packages for Windows

From: Mark Phippard <markphip_at_gmail.com>
Date: Wed, 3 Mar 2010 09:26:38 -0500

On Wed, Mar 3, 2010 at 5:46 AM, Troy Simpson <troy_at_ebswift.com> wrote:
> A minimum level of support would be a good thing to agree on.  Bear in mind the pre-stated
> complexities in handling too many supported installations.  Maybe start at the baseline of 2.2x
> apache support and see if a volunteer is able to deliver builds for that?

When you talk about Apache 2.2 support I assume you mean you need
mod_dav_svn and not just to have SVN compiled against Apache 2.2's
version of APR?

One other "pain" I thought of is that ideally the binaries should be
built using MSVC 6.0 (I am assuming DJ has not changed that). Since
the httpd binaries are built using that you can have problems if a
newer Visual Studio is used for mod_dav_svn. You also have to deal
with distributing the MS runtime libraries if a newer version is used.

The "pain" is that is not possible to obtain a legal copy of MSVC 6.0
anymore. So unless you already have a copy you cannot get it.

Building with Visual Studio 2008 is a lot simpler but has these other
problems to contend with.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
Received on 2010-03-03 15:27:14 CET

This is an archived mail posted to the Subversion Users mailing list.