[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Help!viewvc1.07's problem on suse.

From: fucefu <fucefu_at_163.com>
Date: Fri, 8 Jan 2010 22:40:55 +0800 (CST)

We've installed svn 1.6.6 client, server, and extras via the binaries on suse linux enterprise 10.1 (phython2.4.2, gcc4.1.0,
kernel 2.6.16.46-0.12-smp )and have created a few test repositories. We're able to see the repository list via ViewVC just fine, but when we click on a repository to see its contents, we get the following exception(And other functions are fine) .Any idea why this is happening? I've verified that /opt/CollabNet_Subve​rsion/lib/libserf-0.so.0 exists.
Thanks!
an Exception Has occured
Python Traceback(most recent call last):
File "/opt/CollabNet_Subversion/lib/viewvc/viewvc.py" line 3755, in main request.run_viewvc()
File "/opt/CollabNet_Subversion/lib/viewvc/viewvc.py", line 259, in run_viewvc import vclib.svn
File "/opt/CollabNet_Subversion/lib/svn-phython/svn/__init__.py", line 29, in ? from svn import
fs, repos, core, delta
File "/opt/CollabNet_Subversion/lib/svn-phython/svn/fs.py",line 19,in? from libsvn.fs import*
File "/opt/CollabNet_Subversion/lib/svn-phython/libsvn/fs.py",line 7,in? import_fs
ImportError:/opt/CollabNet_Subversion/lib/libserf-0.so.0: undefined symbol:BIO_set_flags

And than i installed svn 1.5.7, still have the same problem.But on redhat enterprise 5, everything is ok!
Please help!
Thanks in advance!

--
Best regards
Cefu Fu
--
Best regards
Cefu Fu 符策富
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2435771
Please start new threads on the <users_at_subversion.apache.org> mailing list.
To subscribe to the new list, send an empty e-mail to <users-subscribe_at_subversion.apache.org>.
Received on 2010-01-08 15:43:20 CET

This is an archived mail posted to the Subversion Users mailing list.