[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 'make check' Failures, v 1.6.0, x86_64, Centos 5.2

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 2 Apr 2009 16:11:25 +0100

On Thu, Apr 02, 2009 at 09:47:37AM -0500, Hyrum K. Wright wrote:
>
> On Apr 2, 2009, at 7:22 AM, Stefan Sperling wrote:
>> People compiling their own builds run into this problem quite
>> frequently
>> because of bugs in libtool. We cannot fix it, but some of us (e.g. me)
>> are getting increasingly annoyed by it.
>
> Heh. I had a user ask me just the other day about "why aren't the
> subversion libraries versioned so we can have multiple versions (i.e.,
> 1.5.6 and 1.6.0) installed side-by-side?" I really didn't have a good
> answer, but a brain damaged libtool sounds like it's something in the
> right direction.

The libtool documentation explains how to do this.
But we don't do it. I don't know the reason why we don't do it.
I asked someone about it before but I don't remember the answer I got.

http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html#Updating-version-info

Stefan
Received on 2009-04-02 17:12:34 CEST

This is an archived mail posted to the Subversion Users mailing list.