[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

confused by "svn: Copyfrom-url: ... different repository root" error

From: Robert P. J. Day <rpjday_at_crashcourse.ca>
Date: Tue, 3 Feb 2009 05:58:40 -0500 (EST)

after merging painlessly from another repo for weeks and weeks,
recently, i've been getting the occasional error of the form:

svn: Copyfrom-url '<remote new file> has different repository root
than <current repository root>'

  in other words, in the midst of a merge, a file that was *added* in
the remote repository attempts to be added locally and the above error
occurs. i'm confused by this -- *of course* the remote file has a
different repository root; it's in a different repository. why is
that a problem?

  that error doesn't occur with simple mods to existing files, that
works fine. and doing a dry run of the merge first works fine, it's
only the actual merge where that error shows up for added files.

  since this is a fairly recent development, i have no idea where to
look. is there something the remote repo is suddenly doing
differently such that newly-added files have a different property of
some kind that's causing this?

  this is with subversion 1.4.3.

rday

--
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
    Have classroom, will lecture.
http://crashcourse.ca                          Waterloo, Ontario, CANADA
========================================================================
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1096283
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-03 12:01:35 CET

This is an archived mail posted to the Subversion Users mailing list.