[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Subversion 1.5 repository/client compatibility

From: <petesea_at_bigfoot.com>
Date: Mon, 02 Feb 2009 17:03:51 -0800 (PST)

I was hoping someone could clarify a question with regards to
compatibility...

According to the 1.5 release notes:

   ... merge-tracking is not supported unless you upgrade the repository
   as well as the server

OK..., but then later, with regards to "sharding", there's this:

   ... These repositories will only be compatible with other Subversion
   1.5 clients...

Sooo... I read this to mean that in order to support the new
merge-tracking features we need to upgrade the server and the repository.
.. OK, that's fine. But I also read it to mean that if ANY user wants to
use the new merge-tracking features, ALL users will need to upgrade their
clients to 1.5... even the users that don't care about the new 1.5
features?

IS that really true? In other words, a 1.4 (or earlier) client can NOT
access a 1.5 repository?

Also... with regards to upgrading repositories. Can I upgrade ANY
previous repository version with the 1.5 svnadmin upgrade command? ie, if
I have a 1.2 or 1.3 repository can those be upgraded directly to 1.5 or do
they need to first be upgraded to 1.4 (or 1.3)?

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1093752

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-03 03:37:29 CET

This is an archived mail posted to the Subversion Users mailing list.