[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Silly WARNINGs about Ruby and SWIG on Mac OS X 10.4.11 (Tiger) PPC

From: Peter Dyballa <Peter_Dyballa_at_Freenet.DE>
Date: Sat, 3 Jan 2009 16:14:57 +0100


When trying to build the Fink package svn-swig-pm588-1.5.4-1 (made a
local to not use cyrus-sasl) configure complains:

checking for ruby... /usr/bin/false
configure: WARNING: The detected Ruby is too old for Subversion to use
configure: WARNING: A Ruby which has rb_hash_foreach is required to
use the
configure: WARNING: Subversion Ruby bindings
configure: WARNING: Upgrade to the official 1.8.2 release, or later
checking for swig... /sw/bin/swig
checking swig version... 1.3.35
configure: WARNING: Detected SWIG version 1.3.35
configure: WARNING: Subversion requires 1.3.24 or later, and is known
to work
configure: WARNING: with versions up to 1.3.31
configure: Configuring python swig binding

Ruby 1.8.2 (2004-12-25) [powerpc-darwin8.0] exists as /usr/bin/ruby.

SWIG obviously has been detected to be version 1.3.35, as installed.
Why do I get informed that "Subversion requires 1.3.24 or later," etc.?

Is it bad that Ruby was not found?

   Pete      <\
              _\     O  _
             |o \  _\\_/-\='
_____________(_)|-(_)  (_)___________________________________
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-01-27 22:00:55 CET

This is an archived mail posted to the Subversion Users mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.