[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Antwort: Re: compiling subversion with neon <> 0.25.5 [Virus checked]

From: <andreas.kollenbach_at_t-mobile.at>
Date: 2007-06-12 18:29:18 CEST

Hello Kendall,

I installed neon 0.26.3 and the config procedure told me only to use
0.25.5.
If 0.26.1. should work, should 0.26.3 work either?

Greetings
Andi

                                                                           
             Kendall Shaw
             <queshaw@pacbell.
             net> An
                                        users@subversion.tigris.org
             11.06.2007 21:35 Kopie
                                                                           
                                                                     Thema
                                        Re: compiling subversion with neon
                                        <> 0.25.5 [Virus checked]
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           

Erik Huelsmann wrote:
> On 6/11/07, andreas.kollenbach@t-mobile.at
> <andreas.kollenbach@t-mobile.at> wrote:
>>
>> Hello,
>>
>> i tried to compile subversion 1.4.3 with a newer neon library than
>> version
>> 0.25.
>> But the config script insists on version 0.25.5.
>>
>> What's the reason for that behavior?
>> Is there any incompatibility between a lib > 0.25.5 and subversion?
>
> Yes: from the Neon site: "The neon API is subject to
> backwards-incompatible change over minor versions (0.24.x -> 0.25.x)
> but is stable across patch releases (0.24.0 -> 0.24.x)."
>
> This means that new minor releases need to be explicitly verified to
> be backward compatible, or the sources need to be adjusted for the new
> version...

I notice that the INSTALL file says you need 0.25.5 or 0.26.1. So,
shouldn't that mean that the latest neon is compatible?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

__________________________________________________________________________________________

Notice: This e-mail and any attachments are confidential and may be privileged.
If you are not the intended recipient, notify the sender immediately, destroy all
copies from your system and do not disclose or use the information for any purpose.
Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte bevorrechtigtem
Schutz unterliegen. Wenn Sie nicht der beabsichtigte Adressat sind, informieren Sie
bitte den Absender unverzueglich, loeschen Sie alle Kopien von Ihrem System und
veroeffentlichen Sie oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.

T-Mobile Austria GmbH
Geschaeftsfuehrung: Robert Chvatal, Lars Nordmark
Aufsichtsrat: Christopher Schlaeffer (Vorsitzender)
Firmenbuch: Handelsgericht Wien, Sitz Wien, FN 171112k, UID ATU 45011703 DVR 0898295
Konto: BA-CA 52844 072 301, BLZ 12000
__________________________________________________________________________________________

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Jun 12 18:29:50 2007

This is an archived mail posted to the Subversion Users mailing list.