[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SSPI reauthentication during commit fails it

From: techtonik <techtonik_at_gmail.com>
Date: 2007-04-05 08:13:53 CEST

To clarify the issue further I attach full SVN debug log that shows
that failure happened after exactly 100 successful HTTPS requests
when server asked to reauthenticate and there is no dependency or
specific restrictions on requests..

On 3/30/07, techtonik <techtonik@gmail.com> wrote:
> It could be the same, although in my case authentication fails
> immediately on second request if SSPIPerRequestAuth is On. Seems like
> authentication is not dependent on time or amount of traffic, but on
> the exact number of HTTP requests sent to server, because it
> constantly fails at the same file. In my case server allows exactly
> 100 requests without second reauthentication. Grep log with responses
> is attached.
>
>
> On 3/29/07, Samay <getafix123@hotmail.com> wrote:
> > Hi,
> >
> > similar to this http://svn.haxx.se/users/archive-2006-09/1336.shtml?
> >
> > regards
> > S.
> >
> >
> > ----- Original Message -----
> > From: "techtonik" <techtonik@gmail.com>
> > To: <users@subversion.tigris.org>
> > Sent: Thursday, March 29, 2007 10:51 PM
> > Subject: SSPI reauthentication during commit fails it
> >
> > > Hello,
> > >
> > > Yet another problem with Subversion and NTLM / SSPI.
> > > During commit after successful authentcation at the beginning and a
> > > couple of requests afteerward server sends second request to
> > > reauthenticate and at that point commit fails. In my case request for
> > > reauthentication is sent after approximately 230 files 1.1Mb in total,
> > > but it is possible to force reauthentication on every request with
> > > "SSPIPerRequestAuth On" and then commit fails almost immediately.
> > >
> > > I've tried to connect over HTTPS with standard SVN 1.4.3 binary and
> > > with one compiled against Neon 0.25.5 and the result is the same. I
> > > attach log of HTTPS request with "SSPIPerRequestAuth On" using
> > > standard SVN 1.4.3 client binary for windows.
> > >
> > > Any workarounds this time?
> > >
> > > --
> > > --anatoly t.
> > >
> >
> >
> >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > > For additional commands, e-mail: users-help@subversion.tigris.org
> >
>
>
> --
> --anatoly t.
>
>

-- 
--anatoly t.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

Received on Thu Apr 5 08:15:19 2007

This is an archived mail posted to the Subversion Users mailing list.