[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: 1.4.2 build tests fail on windows

From: Andrei Dimitrief-Jianu <andrei_at_allegrowireless.com>
Date: 2007-01-30 22:58:28 CET

Good stuff! I got all the tests running successfully.

Andrei.

-----Original Message-----
From: Lieven Govaerts [mailto:svnlgo@mobsol.be]
Sent: Tuesday, January 30, 2007 2:06 PM
To: Andrei Dimitrief-Jianu
Cc: users@subversion.tigris.org
Subject: Re: 1.4.2 build tests fail on windows

You need to add some lines in your apache configuration to be able to
run the tests. The subversion\tests\cmdline\README file ( or
http://svn.collab.net/repos/svn/trunk/subversion/tests/cmdline/README )
explains it all.

Lieven

Andrei Dimitrief-Jianu wrote:
>
> Good day,
>
> I got the source code for subversion 1.4.2 from the subversion site in

> the zipped form, unzipped it and built the 1.4.2 from source code. The

> build itself is successful but some of the tests performed at the end
> fail.
>
> When running win-tests.py with -c -r -v as command line arguments the
> tests pass. Running the tests through the httpd (python win-tests.py
> -c -r -v -u http://localhost --httpd-port 80) is a different story:
>
> Testing Release configuration on remote repository http://localhost.
>
> Running all tests in getopt_tests.py...success
>
> Running all tests in basic_tests.py...FAILURE
>
> Running all tests in commit_tests.py...FAILURE
>
> Running all tests in update_tests.py...FAILURE
>
> Running all tests in switch_tests.py...FAILURE
>
> Running all tests in prop_tests.py...FAILURE
>
> Running all tests in schedule_tests.py...FAILURE
>
> Running all tests in log_tests.py...FAILURE
>
> Running all tests in copy_tests.py...FAILURE
>
> Running all tests in diff_tests.py...FAILURE
>
> Running all tests in export_tests.py...FAILURE
>
> Running all tests in externals_tests.py...FAILURE
>
> Running all tests in merge_tests.py...FAILURE
>
> Running all tests in revert_tests.py...FAILURE
>
> Running all tests in stat_tests.py...FAILURE
>
> Running all tests in trans_tests.py...FAILURE
>
> Running all tests in autoprop_tests.py...FAILURE
>
> Running all tests in blame_tests.py...FAILURE
>
> Running all tests in special_tests.py...success
>
> Running all tests in svnadmin_tests.py...FAILURE
>
> Running all tests in svnlook_tests.py...FAILURE
>
> Running all tests in svnversion_tests.py...FAILURE
>
> Running all tests in utf8_tests.py...success
>
> Running all tests in history_tests.py...FAILURE
>
> Running all tests in lock_tests.py...FAILURE
>
> Running all tests in cat_tests.py...FAILURE
>
> Running all tests in import_tests.py...FAILURE
>
> Running all tests in svnsync_tests.py...FAILURE
>
> Running all tests in authz_tests.py...FAILURE
>
> I was still able to install it and use it successfully (check-ins,
> check-outs, branching, etc.), so I suspect it is just a configuration
> issue on my build machine.
>
> Are there any tweaks to be put in place in order to get the httpd
> tests pass?
>
> Thank you,
>
> Andrei.
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Jan 30 22:58:55 2007

This is an archived mail posted to the Subversion Users mailing list.