[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: APR with upcomming win32 build of svn1.4

From: Lieven Govaerts <lgo_at_mobsol.be>
Date: 2006-07-31 23:48:44 CEST

john wrote:
> Is there a requirement to build SVN 1.4 (when it's released) with a newer
> version of APR, and hence run on Apache 2.2?
>
> We're currently on Apache 2.0.x and I'm planning the upgrade to SVN 1.4 - will I
> need a Apache upgrade too?
>
> All win32 installs - using the standard binaries.
>
> Thanks,
>
> John

John,

svn 1.4 still supports apr 0.9.x which is included in apache 2.0.x, so
there'll be no need to upgrade to apache 2.2.x.

Note: I'm talking about the source code here. The Subversion project
doesn't release binaries themselves.

The 'standard' binaries for Windows you're referring to are probably the
ones created by Branko ─îibej, who (atleast 'till now) volunteered to
build and package each new Subversion release for Windows. Whether or
not his 1.4 binaries will be build with apr 0.9.x or 1.x is his choice.

If you want to be completely sure and start testing svn 1.4 before
Branko or another volunteer releases the package for Windows, I advise
you to build Subversion from source yourself.

hope this helps,

Lieven.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Jul 31 23:50:03 2006

This is an archived mail posted to the Subversion Users mailing list.