[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Repository relocated to wrong path

From: Andriy Yanov <Andriy.Yanov_at_ericpol.pl>
Date: 2006-03-31 09:54:54 CEST

Madan U S wrote:

>On Thursday 30 Mar 2006 12:40 pm, Andriy Yanov wrote:
>
>
>>Hello everyone,
>>
>>Here is what happened:
>>
>>
>[snip]
>
>
>>The question is: what should be done to correct mistake?
>>
>>
>
>1. I hope you have a backup. :)
>2. To *fix* your working copy, here are the details you need...
>
> - Every folder (1) in the working copy has a .svn folder
> - Every .svn folder has an 'entries' file
> - Every 'entries' file has one entry per version-controlled file present
>in folder(1)
> - It also has params like 'repos:' and 'url:'
> - These 'repos' and 'url' params are used to determine where the repos is
>(you can check this with the 'svn info' command)
>
>
> So, if you can write a script, to tweak these parameters in
>the .svn/entries file for every folder in the wc, to represent the correct
>repos location, you are good to go.
>
> In fact, this is what 'svn switch --relocate' does internally (in
>addition to checking stuff like uid, to make sure both refer to the same
>repos - In your case, its pretty obvious that they are... so you shouldnt
>have to worry about that)
>
>HTH.
>
>Regards,
>Madan.
>
>
>
Thanks, this really helped. Though, my working copy failed to update
correctly, backup copy with modified entries file was updated successfully.

Regards,
Andriy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Mar 31 09:54:07 2006

This is an archived mail posted to the Subversion Users mailing list.