[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: corrupt repository

From: Christopher L Merrill <chris_at_webperformance.com>
Date: 2006-03-22 03:08:43 CET

Ryan Schmidt wrote:
> Is this new area on an NFS mount? If so, BerkeleyDB won't work like that.

nope

> Do you have up-to-date backups? Dumpfiles?

No. I thought about doing a dump...but since it was _supposed_ to be
a simple file move, I didn't. My bad :( I guess I should have researched
the quirks of BDB more.

> Once you get this sorted out, consider moving the repository to FSFS,
> since it cannot suffer from these problems. How to do so is in the FAQ.

That is definitely on my list for this weekend.

FWIW, I'm still not sure exactly what instigated this problem, but somewhere
I found advice to delete some log files and then try a recover. As it turns
out, following that advice exaserbated the problem. Once I realized that
for BDB the log files are actually _important_, I simply restored the files
from a backup, did a recover and viola! Everything back to normal.

Thanks,
Chris

-- 
------------------------------------------------------------------------ -
Chris Merrill                           |  http://www.webperformance.com
Web Performance Inc.
Website Load Testing and Stress Testing Software & Services
------------------------------------------------------------------------ -
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Mar 22 03:11:05 2006

This is an archived mail posted to the Subversion Users mailing list.