[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

AIX Issues: Anyone built/run AIX subversion 1.3 + apache 2.0.55 ???

From: Keith and Teri Kwiatek <kwiatekfamily_at_gmail.com>
Date: 2006-03-19 23:57:51 CET

Hello,

Has anyone AIX user been able to build and run subversion + apache on AIX?

If so, could you give me the configure script parameters you ran with, along
with any envrionment variables you set, and any other things that you
determined needed to be set?

I have AIX 5.2 and am trying to use svn 1.3 and apache 2.0.55.....keepgetting:

$ ./apachectl startssl
Syntax error on line 233 of /u01/weblogic/subversion/Apache/conf/httpd.conf:
Cannot load /u01/weblogic/subversion/Apache/modules/mod_dav_svn.so into
server: rtld: 0712-001 Symbol dav_new_error_tag was referenced\n from
module /u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a
runtime definition\n of the symbol was not found.\nrtld: 0712-001
Symbol dav_push_error was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\nrtld: 0712-001 Symbol
dav_new_error was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\nrtld: 0712-001 Symbol
dav_xml_get_cdata was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\nrtld: 0712-001 Symbol
dav_get_locktoken_list was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\nrtld: 0712-001 Symbol
dav_xmlns_add was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\nrtld: 0712-001 Symbol
dav_register_provider was referenced\n from module
/u01/weblogic/subversion/Apache/modules/mod_dav_svn.so(), but a runtime
definition\n of the symbol was not found.\n\t0509-021 Additional errors
occurred but are not reported

AND if I include mod_dav in httpd.conf I get:
$ ./apachectl startssl
Syntax error on line 232 of /u01/weblogic/subversion/Apache/conf/httpd.conf:
module dav_module is built-in and can't be loaded

LoadModule dav_module modules/mod_dav.so
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so
Received on Sun Mar 19 23:58:33 2006

This is an archived mail posted to the Subversion Users mailing list.