[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Broken repository. svnadmin verify and dump report a checksum mismatch.

From: John Szakmeister <john_at_szakmeister.net>
Date: 2006-02-09 11:45:17 CET

On Thursday 19 January 2006 12:16, John Savage wrote:
> We have a number of developers that use dual CPU windows PCs for their WCs
> and there are no problems. However my issue wasn't client side, it was with
> the server running on a dual CPU system.
>
> Has anyone had any experience hosting svnserve and the repository on a dual
> CPU RAID 1 system (be it windows or otherwise)?

I've setup Subversion both under Windows and Linux with dual CPUs and RAID
subsystems. They've both run for years with no issues. I also host a
repository on my machine at home, which is also a dual CPU system, and I do
all of my Subversion development on it (including stress testing). Never had
a problem.

> My experience was consistent reproducible corruption of the repository on
> the SMP system, which went away only when I moved the repository to a
> single CPU server.

I'm not sure what the deal is here. Perhaps there is something wrong with one
of the drivers for your dual cpu system? As a person who has written a
number of device drivers over the years, I can attest to the fact that many
writers do a lot of things wrong.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Feb 9 12:43:03 2006

This is an archived mail posted to the Subversion Users mailing list.