[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Status of Subversion on the Mac? - SCPlugin

From: Ryan Schmidt <subversion-2006Q1_at_ryandesign.com>
Date: 2006-02-07 11:38:16 CET

On Feb 7, 2006, at 05:40, Rob Brandt wrote:

> I must say that I was unaware of SCPlugin until this post.
>
> I tried to install it and have had no luck. Doesn't come with much
> documentation. I have RapidSVN already installed and working. I
> installed the
> OSX command line client, then SCPlugin and restarted the Mac. I
> went to a
> already checked out working copy and right-clicked, expecting to
> see the svn
> menus, but none appear.
>
> Have I missed something? Using OSX 10.4

I heard about it but hadn't tried it because I read that the current
method wasn't so great (wrapping the Subversion command line program
instead of using the language bindings) and that they were scrapping
the code and rewriting it from scratch. But nothing seems to have
happened since 2004.

I tried installing it just now on 10.4.4 PPC. The little program the
Installer runs to check whether it can be installed crashes for me,
but this didn't prevent me from being able to continue through the
installation. In the preference pane, I told it my Subversion binary
was at /opt/local/bin/svn (this is installed by darwinports; if you
installed another way, the binary will likely be elsewhere, maybe /
usr/local/bin/svn) and told it to enable Finder integration. Then I
quit the Finder (using the Quit menuitem I added with TinkerTool, but
there are other ways, two of which the installer tells you about) and
let it relaunch.

The Subversion submenu appears now in the contextual menu when I
Control-click in the Finder. Some of my working copies also have the
badges now, but some others don't. After quitting the Finder,
different directories have and don't have the badges. After some
trial and error, it appears that the Finder caches directory
contents, and SCPlugin only starts applying badges to the icons after
SCPlugin has been "activated" by choosing one of its menu items. So
if you open working copy 1 and note it has no badges, then select
"Info" from the Subversion submenu in the contextual menu, then open
other working copies (or subdirectories of working copy 1) then those
new directories will have the badges, but working copy 1 still will
not, until you quit the Finder again and "activate" SCPlugin again.
This seems very buggy to me, but that seems to be the workaround.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Feb 7 11:39:41 2006

This is an archived mail posted to the Subversion Users mailing list.