[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Problem with svn move command on Windows

From: Roger Lipscombe <rogerl_at_1e.com>
Date: 2006-02-03 12:11:55 CET

I attempted to move a file from the trunk\Products\Foo30\FooClient
directory to the trunk\Internal directory (names changed slightly to
protect the innocent), as follows:

 

D:\Source\trunk\Products\Foo30\FooClient>svn move update-version.vbs
..\..\..\Internal

A ..\Internal

D update-version.vbs

 

As you can see, svn moved the file up one directory and renamed it to
Internal, rather than moving it to the correct location. It appears to
have ignored the repeated ..\..\..\ bits.

 

It looks like a bug to me. Thoughts?

 

This is version 1.3.0, with SVN_ASP_DOT_NET_HACK=1

 

Cheers,

Roger.

 

This e-mail and any files transmitted with it are confidential and are intended solely for the use of the named addressee. No-one else may use, copy, disclose, distribute or place any reliance on this communication or the information contained herein, unless authorised by 1E. Any views or opinions contained in this communication are those of the author, and 1E does not accept responsibility for them, unless stated otherwise.
If you receive this e-mail in error, please accept our apologies.
1E is a registered company No. 03401322 and its registered office is 18 Bentinck Street, London W1U 2AR
Received on Fri Feb 3 12:13:53 2006

This is an archived mail posted to the Subversion Users mailing list.