[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

v1,3 RC4 is slower, not faster

From: Paul Koning <pkoning_at_equallogic.com>
Date: 2005-12-08 22:45:34 CET

After reading the previous note about V1.3 and speed improvements, I
decided to give it a try. Downloaded V1.3 RC4 and built it (Linux FC4
system).

I only changed the client, left the server along. It's V1.2.3,
svnserve.

The results are quite disappointing. EVERY operation I tried is
clearly slower than V1.2.3.

First I did tests in a working directory checked out by the 1.2.3
client. svn update went from 7:05 to 8:29. svn status went from 7:37
to 9:27.

I then checked out the same repository URL into another working
directory, using the 1.3RC4 client. That checkout took MUCH longer:
27:53 rather than 18:08. And in that new WD, other operations were
even slower than they were with V1.3 in the old working directory: svn
update took 10:52 (vs. 8:29, and 7:05 with the 1.2.3 client) and svn
status took 9:03 (vs 9:27, and 7:37 with the 1.2.3 client).

So it looks like V1.3 has some significant performance problems. I
could try installing the 1.3 svnserve, if there is good reason to
believe that things will then be better than 1.2.3 and not worse.

        paul

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Dec 8 22:49:45 2005

This is an archived mail posted to the Subversion Users mailing list.