[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Installing Subversion on Red Hat 9

From: Philip Radford <phil_at_chycor.com>
Date: 2005-09-20 17:27:32 CEST

Hi all,

I have recently come across subversion for the use of controlling our development projects.

I am attempting to install verson 1.2.3 on Red Hat 9 (Shrike) with limited success.

I have untarred the source distribution, obtained berkeley db 4.3.28 and needed to locate swig 1.3.25 as it could not find that on the system.

After the first configure, make and make install any utility that was run such as svn and svnadmin resulted in a 'segmentation fault' message being displayed.

I then repeated the process making sure to note any errors. The following is an extract from the make install section.

------------------------------------

Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
cd subversion/libsvn_wc ; /bin/sh /usr/local/src/subversion-1.2.3/libtool --mode=install /usr/local/src/subversion-1.2.3/ac-helpers/install-sh -c libsvn_wc-1.la /usr/local/lib/libsvn_wc-1.la
libtool: install: warning: relinking `libsvn_wc-1.la'
(cd /usr/local/src/subversion-1.2.3/subversion/libsvn_wc; /bin/sh /usr/local/src/subversion-1.2.3/libtool --tag=CC --silent --mode=relink gcc -g -O2 -g -O2 -pthread -DNEON_ZLIB -rpath /usr/local/lib -o libsvn_wc-1.la adm_crawler.lo adm_files.lo adm_ops.lo copy.lo diff.lo entries.lo lock.lo log.lo merge.lo props.lo questions.lo relocate.lo status.lo translate.lo update_editor.lo util.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la ../../subversion/libsvn_diff/libsvn_diff-1.la /usr/local/src/subversion-1.2.3/apr-util/libaprutil-0.la -lgdbm -ldb-4.0 -lexpat /usr/local/src/subversion-1.2.3/apr/libapr-0.la -lrt -lm -lcrypt -lnsl -lpthread -ldl )
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libdb-4.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libdb-4.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libdb-4.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../..//libexpat.la' seems to be moved
/usr/local/src/subversion-1.2.3/ac-helpers/install-sh -c .libs/libsvn_wc-1.so.0.0.0T /usr/local/lib/libsvn_wc-1.so.0.0.0
(cd /usr/local/lib && rm -f libsvn_wc-1.so.0 && ln -s libsvn_wc-1.so.0.0.0 libsvn_wc-1.so.0)
(cd /usr/local/lib && rm -f libsvn_wc-1.so && ln -s libsvn_wc-1.so.0.0.0 libsvn_wc-1.so)
/usr/local/src/subversion-1.2.3/ac-helpers/install-sh -c .libs/libsvn_wc-1.lai /usr/local/lib/libsvn_wc-1.la
/usr/local/src/subversion-1.2.3/ac-helpers/install-sh -c .libs/libsvn_wc-1.a /usr/local/lib/libsvn_wc-1.a
ranlib /usr/local/lib/libsvn_wc-1.a
chmod 644 /usr/local/lib/libsvn_wc-1.a
PATH="$PATH:/sbin" ldconfig -n /usr/local/lib

------------------------------------

I can only assume that this linking warning is the cause of subversion not compiling correctly and therefore not running.

It seems to be that it is looking for libdb-4.0.la which is not on the system but I have supplied the path to the latest berkeley db using the configure command :-

./configure --with-apr=/usr/local/apache --with-apr-util=/usr/local/apache -with-berkeley-db=/usr/local/src/db-4.3.28 --with-swig=/usr/local

I would be grateful for any advice or guidance in this matter.

Regards
Philip Radford.
Received on Tue Sep 20 20:25:02 2005

This is an archived mail posted to the Subversion Users mailing list.