[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

LOCK gives me "Method Not Allowed"

From: James Carroll <jim_at_microbrightfield.com>
Date: 2005-06-08 00:46:01 CEST

 

Hi, I just upgraded my server to 1.2 and am using Tortoise SVN 1.2 as
well. (I'm not on the list, please CC me)

 

Commits and Updates work fine.

I'm trying to test out the exclusive lock mechanism, and when I try to
lock something

I get the 405 Method Not Allowed error.

 

My Apache logs look like:

 

error.log:

  [Tue Jun 07 18:01:58 2005] [error] [client 192.168.1.100] The
requested report is unknown. [501, #200007]

 

And access.log:

192.168.1.100 - - [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 401 509

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 207 702

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/!svn/vcc/default HTTP/1.1" 207 396

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/!svn/bln/8 HTTP/1.1" 207 447

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 207 702

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/!svn/vcc/default HTTP/1.1" 207 396

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/!svn/bln/8 HTTP/1.1" 207 447

192.168.1.100 - - [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 401 509

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 207 702

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "PROPFIND
/svn/vss/!svn/vcc/default HTTP/1.1" 207 447

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:35:59 -0400] "REPORT
/svn/vss/!svn/bc/8/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 200 161093

192.168.1.100 - - [07/Jun/2005:18:36:35 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 401 509

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:36:35 -0400] "PROPFIND
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 207 702

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:36:35 -0400] "PROPFIND
/svn/vss/!svn/vcc/default HTTP/1.1" 207 396

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:36:35 -0400] "PROPFIND
/svn/vss/!svn/bln/8 HTTP/1.1" 207 447

192.168.1.100 - BRIGHT\\jim [07/Jun/2005:18:36:35 -0400] "LOCK
/svn/vss/STEREO/DefineComboMarkerDlg.cpp HTTP/1.1" 405 369

 

When I did the upgrade, I followed the readme.txt and deleted the unused
log files in the repository etc...

 

I also upgraded apache to the latest (2.0.54) on the advise of the
installer.

(I'm not on the list, please CC me)

 

The only thing I can think of is that I haven't rebooted my server, so
there might be something stale from the previous install that doesn't
know what a lock is.

 

Thanks,

-Jim

 

 

 

 
Received on Wed Jun 8 01:14:44 2005

This is an archived mail posted to the Subversion Users mailing list.