[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svn merge: working copy locked, but it's not

From: David Pankros <dpankros_at_miragy.com>
Date: 2005-05-18 21:23:53 CEST

I've tried searching for information about this but I can't find
anything. There's always the chance that I missed something, so I
apologize if this has been asked before.

I've been having an issue with subversion and merging. I first tried it
with tortoise but since that gave me an error, I switched to the command
line to rule out any extra issues. I'm using svn 1.1.4 on both the
client and server. The server is running with apache/dav.

I have a repo that looks roughly like this (unnecessary parts pruned):

http://svn/repo
  |
  +--branches
  | +--1.0-beta1
  | +--module1
  | +--module2
  | +--module3
  | +--(and so on...)
  |
  +--trunk
       +--product
            +--module1
            +--module2
            +--module3
            +--(and so on...)

I want to merge the changes FROM THE TRUNK to the branches/1.0-beta1
directory. (Yes, I know it's a little backward, and I'm changing my
overall strategy after this merge.)

I have already merged one change to the 1.0-beta1 branch successfully:
C:\views\1.0-beta1>svn log --stop-on-copy
------------------------------------------------------------------------
r296 | dpankros | 2005-04-22 11:57:20 -0500 (Fri, 22 Apr 2005) | 1 line

Merged fix for bug#38.
------------------------------------------------------------------------
r290 | dpankros | 2005-04-12 12:36:48 -0500 (Tue, 12 Apr 2005) | 1 line

Created 1.0-beta1 branch.
------------------------------------------------------------------------

And I just checked out the working copy:
C:\views\1.0-beta1>svn status
(no output)

Trying to merge using --dry-run is successful and shows the correct
files updated, AFAICT. So I try to merge my changes to the branch:
C:\views\1.0-beta1>svn merge -r 297:HEAD http://svn/repo/trunk/product
U module1\project.xml
U module1\maven.xml
svn: Working copy 'module1\src\java\META-INF' locked
svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for
details)

I've tried other forms of the merge command, but they all fail at the
same place.

Just for kicks, I see if I can confirm what it is saying:
C:\views\1.0-beta1>svn status
M module1\project.xml
M module1\maven.xml

But there are no locks. I can try running "svn cleanup", but the merge
will give the same error again. So what's the deal here? Does anyone
have any clue why it says it's locked when it clearly is not? What
should I check first?

Thanks,
Dave

-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.308 / Virus Database: 266.11.12 - Release Date: 5/17/2005
 
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed May 18 21:23:34 2005

This is an archived mail posted to the Subversion Users mailing list.