[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Apache and Subversion give bad request on checkout

From: Célio Cidral Junior <ccidral.newsbox_at_gmail.com>
Date: 2005-05-06 18:07:22 CEST

This is how the location is now configured:

<Location /repos/cds>
        DAV svn
        SVNPath c:/dev/codebase/cds
</Location>

But that error keeps chasing me :'-(
Note that listing the repository works well.

C:\Temp>svn list http://m195601.weg.net/repos/cds
crmweg/
sycamore/

C:\Temp>svn checkout http://m195601.weg.net/repos/cds/sycamore sycamore
svn: Requisição REPORT falhou em '/repos/cds/!svn/vcc/default'
svn: REPORT de '/repos/cds/!svn/vcc/default': 400 Bad Request
(http://m195601.weg.net)

Celio

2005/5/6, Frank Gruman <fgatwork@verizon.net>:
> Is your repository located at c:/dev/codebase, or at c:/dev/codebase/cds??
>
> You have set the SVNParentPath as c:\dev\codebase, which means it looks for
> the repository right at that level, not another level down...
>
> You need to do one of two things:
>
> Two Options:
>
> 1. Change your repository location to be directly in the codebase folder,
> or
>
> 2. Get rid of the SVNParentPath and use SVNPath and point to the cds
> directory.
> If you have multiple repositories spread across different directories,
> you can have multiple <Location> directives (with unique names, of course).
>
> Give it a whirl.
>
> Regards,
> Frank
>
>
> Célio Cidral Junior wrote:
> I changed the slashes, but it's not working yet. It seems that Apache
is not
> allowing requests like REPORT and MKACTIVITY. I can browse the
repository
> via web browser, so it's accepting GET requests. It's
strange because I'm
> loading the dav and svn_dav modules in the config
file. Anyway, I'm not an
> Apache guy so I'm pleased if some Apache
experienced folk could help me on
> this issue.

C:\>svn mkdir
> http://brjgs734.weg.net/repositories/cds/sycamore/temp
-m
> "Testing"
svn: MKACTIVITY of
> '/repositories/cds/!svn/act/8beb94c9-a68b-af41-b1e5-46221d28
11c':
> 400 Bad Request (http://brjgs734.weg.net)

Thanks!!

Celio

2005/5/6, Peter
> McNab <mcnab_p@melbpc.org.au>:
 
> Célio Cidral Junior wrote:

 
> Hello!

I installed Apache and Subversion on my machine, and configured
> them
exactly as the book tells about configuration of the server. But
> the
server gives me the error below when I try to checkout. Note
> that
everything is on my machine, so there is no proxy or firewalls on
> the
way.

C:\>svn list
> http://m195601.weg.net/repositories/cds/sycamore
trunk/

C:\>svn
> checkout http://m195601.weg.net/repositories/cds/sycamore
> sycamore
svn: REPORT request failed on
> '/repositories/cds/!svn/vcc/default'
svn: REPORT of
> '/repositories/cds/!svn/vcc/default': 400 Bad
> Request
(http://m195601.weg.net)

The httpd.conf is configured pretty much
> this way:

LoadModule dav_module modules/mod_dav.so
LoadModule
> dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module
> modules/mod_authz_svn.so

<Location /repositories>
 DAV svn
 SVNParentPath
> c:/dev/codebase
</Location>

Can someone point me out to what can be
> wrong?

Thanks in advance!

 
> If thats a windows box then you need backslashes \ not / .
> c:\dev\codebase

Peter

---------------------------------------------------------------------
To
> unsubscribe, e-mail:
> users-unsubscribe@subversion.tigris.org
For additional
> commands, e-mail: users-help@subversion.tigris.org

 
>
 
>

-- 
Célio Cidral Junior
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri May 6 18:10:16 2005

This is an archived mail posted to the Subversion Users mailing list.