[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

hot-backup stopped working

From: Benjamin Zeiss <bnz_at_zeiss.net>
Date: 2005-01-28 12:45:19 CET

hi,

recently my hot-backup script stopped working. strangely everything else
works fine and svnadmin recover doesn't fix anything. svnadmin verify
states that everything is fine. this is the error message:

svn: Error running catastrophic recovery on hotcopy; the
DB_LOG_AUTOREMOVE feature may be interfering with the
hotcopy algorithm. If the problem persists, try deactivating
this feature in DB_CONFIG.
svn: DB_RUNRECOVERY: Fatal error, run database recovery
svn: bdb: Logging region out of memory; you may need to increase its size
svn: bdb: Recovery function for LSN 448 232828 failed on backward pass
svn: bdb: PANIC: Cannot allocate memory
svn: bdb: PANIC: fatal region error detected; run recovery
svn: bdb: PANIC: fatal region error detected; run recovery
svn: bdb: PANIC: fatal region error detected; run recovery
svn: bdb: PANIC: fatal region error detected; run recovery
[cut a lot of duplicate lines of this kind]

do you have an idea what that should tell me? i really should make the
backup work again you know :-)

--
Benjamin Zeiss
GPG: 0xC398BCC6
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jan 28 12:46:35 2005

This is an archived mail posted to the Subversion Users mailing list.