[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: RH9 -> FC3 upgrade breaks svn: can't find libdb-4.0.so

From: Kris Deugau <kdeugau_at_vianet.ca>
Date: 2005-01-19 16:23:18 CET

Martin wrote:
> I'm trying, but at this stage I'm completely stuffed.
>
> everything else works; why is it optimistic? i should be able to
> upgrade without problems.

Except where you have data files created by an older BerkelyDB library
version. There is usually a program included in one of the dbnn
packages (probably db42-4.2something for FC3) to supposedly "upgrade"
those files to work with the new version of the library, but I've only
found it once on any of my systems, and IIRC it failed miserably.
Fortunately the data in that case was non-critical.

You'll probably have to dig up the old third-party Subversion packages,
and an appropriate db4 package, and hope you can install them without
massive dependency chains causing problems. You *may* have to go to the
effort of rebuilding them, dumping your repo, installing the FC3
packages and then reloading your repo.

-kgd

-- 
Get your mouse off of there!  You don't know where that email has been!
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jan 19 16:26:08 2005

This is an archived mail posted to the Subversion Users mailing list.