[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: RH9 -> FC3 upgrade breaks svn: can't find libdb-4.0.so

From: Martin <m.e_at_acm.org>
Date: 2005-01-19 12:22:01 CET

I'm trying, but at this stage I'm completely stuffed.

everything else works; why is it optimistic? i should be able to upgrade
without problems.

Martin

Max Bowsher wrote:
> Martin wrote:
>
>> I get the following message when I try to run svn:
>>
>> svn: error while loading shared libraries: libdb-4.0.so: cannot open
>> shared object file: No such file or directory
>>
>> I previously had svn running happily under RH9. I forget how I installed
>> it but it was probably by downloading the RPM.
>>
>> Then I upgraded to FC3 and as part of that, it installed its own copy of
>> svn, and then I started getting that message. I downloaded the latest
>> rpm and installed it, but I am still getting the same error. svn is not
>> working at all, so I made this a P1.
>>
>> Please advise on what I need to do to fix this.
>
>
>
> Upgrading over 3 versions of a distribution, with 3rd party rpms
> installed not expecting them to break is a little... optimistic... IMO.
>
> Anyway, it seems to me the obvious thing to do would be to remove all
> traces of 3rd party db and subversion packages, and use the FC3 official
> ones.
>
> Max.
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jan 19 12:28:22 2005

This is an archived mail posted to the Subversion Users mailing list.