[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Failed compile

From: simon t <subversion.users_at_gmail.com>
Date: 2004-09-29 18:50:41 CEST

Hi I'm trying to install subversion and I'm running into problems.
The configure and make run fine but the make install is failing.

I am running:
./configure --without-apache --without-apxs --disable-mod-activation
--prefix=/usr/local/pub/Linux
make
make install prefix=/usr/local/pub/Linux/stow/subversion-1.08

The error I get is:
<snip>
gcc: ../../subversion/libsvn_client/.libs/libsvn_client-1.so: No such
file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_wc/.libs/libsvn_wc-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_ra/.libs/libsvn_ra-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_ra_local/.libs/libsvn_ra_local-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_repos/.libs/libsvn_repos-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_fs/.libs/libsvn_fs-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_ra_dav/.libs/libsvn_ra_dav-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_ra_svn/.libs/libsvn_ra_svn-1.so:
No such file or directory
gcc: ../../subversion/libsvn_subr/.libs/libsvn_subr-1.so: No such file
or directory
gcc: ../../subversion/libsvn_wc/.libs/libsvn_wc-1.so: No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_delta/.libs/libsvn_delta-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_diff/.libs/libsvn_diff-1.so:
No such file or directory
gcc: /home/dsk39/pub/packages/subversion-1.0.8/subversion/libsvn_subr/.libs/libsvn_subr-1.so:
No such file or directory
make: *** [revision-install] Error 1

It seems that libsvn_subr-1.so is a link to libsvn_subr-1.so.0.0.0 but
that file does not exist, libsvn_subr-1.so.0.0.0U does exist but
correcting the link and rerunning still gives me the same problem. Is
there something i'm missing?

Further info
Linux ui06 2.4.27 #4 SMP Fri Sep 3 18:52:43 MDT 2004 i686 unknown
unknown GNU/Linux
subversion version: 1.0.8

Thanks

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Sep 29 18:51:08 2004

This is an archived mail posted to the Subversion Users mailing list.