[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: setting up apache/subversion...

From: Kevin Bentley <kevin.bentley_at_gmail.com>
Date: 2004-09-06 19:43:11 CEST

"Bad database version: compiled with 4.0.14, running
against 4.2.52"

This is the real problem, the other errors are because the paths aren't correct.

I'm not sure if this is because of a conflict between how Apache was
compiled and how Subversion was compiled (Subversion made the db files
as one version, but apache is accessing it as a different version), or
because of some library path problem. Rebuilding apache and
subversion, both using the same berkeley database libraries should fix
it, but is not a trivial task.

On Mon, 6 Sep 2004 10:24:13 -0700, bruce <bedouglas@earthlink.net> wrote:
> ok...
>
> in testing, i've made minor changes to the httpd.conf file in order to test
> the 'SVNPath' /snvroot/svn
>
> SVNPath /snvroot/svn
> err log file
> [Mon Sep 06 10:33:35 2004] [error] [client 192.168.1.52] (20014)Error string
> not specified yet: Bad database version: compiled with 4.0.14, running
> against 4.2.52
>
> SVNPath /snvroot/
> err log file
> [Mon Sep 06 10:32:35 2004] [error] [client 192.168.1.52] (20014)Error string
> not specified yet: Can't open file '/svnroot/format': No such file or
> directory
>
> SVNPath /snvroot
> err log file
> [Mon Sep 06 10:27:50 2004] [error] [client 192.168.1.52] (20014)Error string
> not specified yet: Can't open file '/svnroot/format': No such file or
> directory
>
> -------------------
>
> [root_at_lserver2 collegewcopy]# svn list http://192.168.1.52:82/svn
> svn: PROPFIND request failed on '/svn'
> svn:
> Could not open the requested SVN filesystem
>
> -------------------
>
> as far as i can tell, i'm getting the same 'PROPFIND' request err,
> regardless of changes made to the httpd.conf file, regarding the 'SVNPath'
> attribute...
>
> searching through google has not shed any light on this issue.. again, the
> actual repository location is:
> '/svnroot/svn'
> the files under the repository are:
> '/svnroot/svn'
> /conf /lock ...etc...
>
> as i'm not sure what the real issue is, i'm not inclined to want to start
> building/installing things from source as this could simply screw things up
> even more.
>
> i'm able to run svnserve and access the repository using the svn client...
> so i'm somewhat sure that the actual repository with the db is working ok..
>
> this is rather curious...
>
> pointers/comments/thoughts/etc...
>
> i'm running
> rh8.0
> httpd Server version: Apache/2.0.50
> Server built: Jun 29 2004 11:11:55
>
> regards,
>
> -bruce
>
>
>
> -----Original Message-----
> From: Kevin Bentley [mailto:kevin.bentley@gmail.com]
> Sent: Monday, September 06, 2004 9:27 AM
> To: bedouglas@earthlink.net
> Cc: users@subversion.tigris.org
> Subject: Re: setting up apache/subversion...
>
> You said the repository was in /svnroot/svn, but Apache is complaining
> about /svnroot/format not being readable. It should be getting that
> file in /svnroot/svn/format according to the configuration you posted.
>
> For the record, you should be using the URL
> http://192.168.1.52:82/svn, and it should get files from /svnroot/svn.
> Make double sure all your config files are correct, and that you don't
> have duplicate <Location /svn> sections in your log file.
>
> On Mon, 6 Sep 2004 09:18:46 -0700, bruce <bedouglas@earthlink.net> wrote:
> > here's the latest msgs and information from the error/access log file for
> > apache.... it appears that it can't find the /svnroot dir.. although the
> dir
> > exists...
> >
> > error_log ouptut
> > [root@lserver2 collegewcopy]# cat /var/log/httpd/error_log
> > [Mon Sep 06 09:37:00 2004] [notice] Apache/2.0.50 (Fedora) PHP/5.0.0
> > mod_python/3.1.3 Python/2.3.3 DAV/2 SVN/1.0.6 configured -- resuming
> normal
> > operations
> > [Mon Sep 06 09:37:12 2004] [error] [client 192.168.1.52] (20014)Error
> string
> > not specified yet: Can't open file '/svnroot/format': No such file or
> > directory
> > [Mon Sep 06 09:37:12 2004] [error] [client 192.168.1.52] Could not fetch
> > resource information. [500, #0]
> > [Mon Sep 06 09:37:12 2004] [error] [client 192.168.1.52] Could not open
> the
> > requested SVN filesystem [500, #2]
> > [Mon Sep 06 09:37:12 2004] [error] [client 192.168.1.52] Could not open
> the
> > requested SVN filesystem [500, #2]
> >
> > access log output
> > 192.168.1.52 - - [06/Sep/2004:09:37:12 -0700] "PROPFIND /svn HTTP/1.1" 500
> > 234 "-" "SVN/1.0.6 (r10360) neon/0.24.7"
> > 192.168.1.52 - - [06/Sep/2004:09:37:21 -0700] "PROPFIND /svnroot HTTP/1.1"
> > 405 369 "-" "SVN/1.0.6 (r10360) neon/0.24.7"
> >
> > so, i'm willing to bet that the config file is not correctly configured..
> > but i can't tell what needs to be modified...
> >
> > any thoughts/comments/pointers..
> >
> > thanks...
> >
> > regards,
> >
> > -bruce
> >
> >
> >
> >
> > -----Original Message-----
> > From: bruce [mailto:bedouglas@earthlink.net]
> > Sent: Monday, September 06, 2004 8:49 AM
> > To: 'Patrick Smears'; users@subversion.tigris.org
> > Subject: RE: setting up apache/subversion...
> >
> > ok...
> >
> > my bad!!! made the change to the cmd line... and i get
> >
> > [root_at_lserver2 collegewcopy]# svn list http://192.168.1.52:82/svn
> > svn: PROPFIND request failed on '/svn'
> > svn:
> > Could not open the requested SVN filesystem
> >
> > [root_at_lserver2 collegewcopy]# svn list http://192.168.1.52:82/svnroot/svn
> > svn: PROPFIND request failed on '/svnroot/svn'
> > svn: PROPFIND of '/svnroot/svn': 405 Method Not Allowed
> > (http://192.168.1.52:82)
> >
> > the group/owner of the /svnroot tree is apache/apache which is the same as
> > the apache/httpd process...
> >
> > the httpd.conf is the same. (however i tried to change the SVNPath to
> > 'svnroot/svn' / 'svnroot' to see if it made a difference with what gets
> > returned.... it doesn't...
> >
> > any ideas...
> >
> > the actual test repository is /svnroot/svn....
> >
> > regards,
> >
> > -bruce
> >
> > LoadModule dav_module modules/mod_dav.so
> > LoadModule dav_svn_module modules/mod_dav_svn.so
> > <Location /svn>
> > DAV svn
> > SVNPath /svnroot/svn
> > #
> > # # Limit write permission to list of valid users.
> > # <LimitExcept GET PROPFIND OPTIONS REPORT>
> > # # Require SSL connection for password protection.
> > # # SSLRequireSSL
> > #
> > # AuthType Basic
> > # AuthName "Authorization Realm"
> > # AuthUserFile /absolute/path/to/passwdfile
> > # Require valid-user
> > # </LimitExcept>
> > </Location>
> >
> > -----Original Message-----
> > From: Patrick Smears [mailto:patrick.smears@ensoft.co.uk]
> > Sent: Monday, September 06, 2004 8:37 AM
> > To: 'bedouglas@earthlink.net'; users@subversion.tigris.org
> > Subject: RE: setting up apache/subversion...
> >
> > > in order to use apache/httpd, do i need to have anything running
> > > (svn/svnserve) on the server, other than apache/httpd of course!
> >
> > No, just apache should be fine...
> >
> > > in my server, i have '/svnroot/svn' setup to be the basic
> > > repository. i can
> > > access this via the 'svnserve/svn' apps, so it seems to be ok.
> > >
> > > however, when i try to do a:
> > > svn list http:://192.168.1.52:82/svnroot/svn
> > > svn list http:://192.168.1.52:82/svnroot
> > >
> > > i get a
> > > svn: 'http::/192.168.1.52:82/svnroot' is not a working copy
> > > or a
> > > svn: 'http::/192.168.1.52:82/' is not a working copy
> >
> > I think you mean "http://" (one colon, two slashes) rather than
> "http::/"...
> >
> > -P
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Sep 6 19:43:53 2004

This is an archived mail posted to the Subversion Users mailing list.