[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: I'm at my wits end. (Subversion merge stupidity)

From: Mike Javorski <mjavorski_at_spokesoftware.com>
Date: 2004-08-05 00:48:35 CEST

I will try and work up some recipes for both these issues and post them.

- mike

-----Original Message-----
From: kfogel@newton.ch.collab.net [mailto:kfogel@newton.ch.collab.net]
On Behalf Of kfogel@collab.net
Sent: Wednesday, August 04, 2004 7:13 AM
To: Mike Javorski
Cc: users@subversion.tigris.org
Subject: Re: I'm at my wits end. (Subversion merge stupidity)

"Mike Javorski" <mjavorski@spokesoftware.com> writes:
> There is two problems, one is really annoying/frustrating, the other
is
> just annoying:
>
> Problem #1:
> ===================
>
> We go through the following steps:
>
> - mkdir webstage/demo, insert some stuff into the new dir, commit
> .
> . Other stuff happens here that is irrelevent to this example
> .
> - mkdir active/demo, insert some other stuff into the new dir, commit
> - change some files in webstage/demo and commit
> .
> . Now it gets interesting.
> .
> >From active, run svn merge ./@HEAD ../webstage@HEAD and what do I see
>
> *SNIP*
> D demo/file1.html
> D demo/file2.html
> D demo
> Svn: Revision 134619188 doesn't match existing revision 339 in 'demo'
> *SNIP*

Wow, do you really have a revision 134619188?

I suspect something funny is going on here. If you can reproduce this
error reliably (i.e., with a short demo script that creates a
repository from scratch, sets things up appropriately, and then shows
the above behavior -- albeit with different revision numbers, of
course) I'd love to take a look.

> Now active/demo is empty, and the files marked as deleted. This makes
no
> sense whatsoever, there should be either a fault, and svn merge should
> fail indicating that it can't determine how to merge, or (preferably)
> should delete the old files and place the merged files in the
directory
> like I told it to. I have fixed this in the past by deleting one
> directory, and commiting a fresh copy. Doing that seems to clear the
> issue, but the issue really shouldn't happen to begin with.

Yeah, it doesn't make any sense to me either. A complete transcript
is what we need here, I think.

> Problem #2:
> ==============
> For some reason (on the same repository as above) svn merge thinks it
> ALWAYS has to merge over some of the image files. When I go to commit
> the directory, it doesn't include them, so that's fine, but the
problem
> is it ALWAYS thinks they are out of sync. These image files were
copied
> from webstage/ to active/ within svn, but it for some reason still
> thinks there is a versioning delta between them and proceeds to
re-copy
> them on each merge attempt. This is not a drastic problem, but it is
> very annoying when you are trying to figure out what files are being
> merged, and for some people on remote, can cause a considerable time
> delay as it recopies the files.

Again, we need a full transcript, showing the commmands you're running
and their output, and anything else you think might possibly be
relevant.

Thanks,
-Karl

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Aug 5 00:48:55 2004

This is an archived mail posted to the Subversion Users mailing list.