[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion version compatability

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2003-09-17 20:32:01 CEST

"Oxley, David" <David.Oxley@workplace-systems.plc.uk> writes:

> We have just upgraded our server to 0.29.0, but our developers are
> distributed across the country and they may be running earlier versions. A
> couple of questions:
> 1. Will using an earlier version cause any corruption in the repository?

Corruption? Not at all. You might get network errors.

> 2. What problems will our developers encounter?

Network failures, due to changing network protocols. A 0.29 server is
only "guaranteed" (in the sense of tech support) to work with a 0.29
or 0.28 client. It may or may not work with an eariler client.

> 3. Can't the client be changed to output an error if it tries to talk to an
> incompatible server? (i.e. The server is running 0.29.0, please upgrade your
> client to 0.28.0 or above.)

This request has come up over and over, and has (in my memory) led to
long arguments about how to implement this... but never bore any
fruit. :-(

To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Sep 17 20:33:11 2003

This is an archived mail posted to the Subversion Users mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.