[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN IP Changed

From: Narender Singh <narendermann_at_gmail.com>
Date: Tue, 7 Feb 2017 14:54:23 +0530

Hello Experts! Any suggestions or help very much appreciated here.

*Thanks, Narender Singh*

On 31 January 2017 at 14:54, Narender Singh <narendermann_at_gmail.com> wrote:

> Hello Stefan!
>
> First of all thanks for your reply and suggestion.
>
> I did checkout and it gave the same error. Now here is the svn info output
> which shows old IP which is down.
>
> *svn info*
> Path: .
> Working Copy Root Path: path/svn/PATH/PATH
> URL: svn://OLDIP.ADD.XX.XX/path/svn/PATH
> Relative URL: ^/
> Repository Root: svn://OLDIP.ADD.XX.XX/path/svn/PATH
> Repository UUID: c55ba37c-5417-44dd-83d4-87b544300aaa
> Revision: 1565
> Node Kind: directory
> Schedule: normal
> Last Changed Author: user1
> Last Changed Rev: 1565
> Last Changed Date: 2016-04-18 06:37:33 -0400 (Mon, 18 Apr 2016)
>
>
>
>
> *Thanks, Narender Singh*
>
> On 30 January 2017 at 21:58, Stefan Hett <stefan_at_egosoft.com> wrote:
>
>> Hi Narender,
>>
>> On 1/30/2017 4:01 PM, Narender Singh wrote:
>>
>> ​
>> Hello Experts,
>>
>> I have SVN Server running on linux which is recently migrated to another
>> server. means IP address changed. Now I tried accessing it through client
>> and ssh, it says
>>
>> svn: E000110: Unable to connect to a repository at URL '
>> svn://OLDIP.ADD.XX.XX/path/svn/PATH'
>> svn: E000110: Can't connect to host 'OLDIP.ADD.XX.XX': Connection timed
>> out
>>
>> where OLDIP.ADD.XX.XX is the old IP and NEWIP.ADD.XX.XX is the new IP.
>>
>> Now when I runs svn relocate it given below error:
>>
>> svn: E210005: Unable to connect to a repository at URL '
>> svn://NEWIP.ADD.XX.XX/path/svn/PATH'
>> svn: E210005: No repository found in 'svn://NEWIP.ADD.XX.XX/path/sv
>> n/PATH'
>>
>> SVN LIST output:
>>
>> svn list
>> svn: E000110: Unable to connect to a repository at URL 'svn://OLD
>> IP.ADD.XX.XX/path/svn/PATH'
>> svn: E000110: Can't connect to host 'OLDIP.ADD.XX.XX': Connection timed
>> out
>>
>> Can you please help me it resolving this ?
>>
>>
>>
>> *Thanks, N ​S *
>>
>> looks like there's a problem communicating with the new server. Try a
>> simple checkout of the repository using the new server URL to be sure. I
>> expect this to fail too.
>> FWIW: Using the relocate operation is the right way to go. So that part
>> you got correct.
>>
>> You need to check out the communication error on the new webserver. It
>> can be a multitude of causes including svnserver not running, firewall,
>> port mismatch, privilege issues of the svnserve-process.
>> Alternatively your client might be restricted to access the new webserver
>> (check the firewall settings and general accessibility of the new webserver
>> from the client).
>>
>> The webserver logs should point you in the right direction.
>>
>> --
>> Regards,
>> Stefan Hett
>>
>>
>

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3207260

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2017-02-07 10:25:17 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.