[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug report: source tree not being recognized

From: <bob.kast_at_emc.com>
Date: Tue, 27 Dec 2011 12:23:29 -0500

I've noticed a bug that started with 1.7.3:

I have a dir (c:\blds) where I checkout all the different projects/branches. I have a tag checked out (GD.AVfix) at:
C:\blds\GD.AVfix

After the upgrade, if I right-click (in Explorer) on the above directory, it doesn't know it is a repository. The only SVN items in the menu are: SVN Checkout.., TortoiseSVN->..

In other words, I don't get the "Update", "Commit", "Check for Modifications", items.

The right-click menu doesn't show these, but I still DO get the green checkmark icon overlay over the folder icon, which does indicate that SVN knows it is a repository.

This dir does contain a ".svn" directory.

To fix it, I deleted the repository directory and tried checking it out again. It all checked out okay, but I still wasn't able to do the normal functions (Update/Commit, etc.). I deleted it again, and this time checked out that branch, but to this dir:

C:\blds\avfix

This time it worked! It appears to not like the directory name that matched the branch tag (GD.AVfix)!

This same behavior is happening on 3 different machines. There is ONE where the upgrade didn't seem to break this directory. Maybe the difference between this one and the rest is that the one that works is XP. The machines that are showing this apparent bug are all Win7 and 2008R2 (all x64).

Thanks,
Bob

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2902496

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-12-31 03:04:58 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.