[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: TortoiseSVN - Issues when working in a sub-dir within a WC - "svn: warning: W155007: '.' is not a working copy"

From: <javier.jarava_at_rsa.com>
Date: Fri, 25 Nov 2011 03:23:32 -0500

Hi, Stefan…

UAC is not enabled in the machine – Company policy.

Attached you can find a zip file with the PROCMON .pml trace of the activity of the svn.exe command while performing the following actions:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\es\Gobierno_Canario\SIEM_Pliego
>svn st
svn: warning: W155007: '.' is not a working copy

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\es\Gobierno_Canario\SIEM_Pliego
>cd ..

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\ES\Gobierno_Canario
>svn st

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\ES\Gobierno_Canario
>cd SIEM_Pliego

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\ES\Gobierno_Canario\SIEM_Pliego
>svn st

C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort\ES\Gobierno_Canario\SIEM_Pliego
>

To get to that directory, I did WIN+R, opened the folder directly and from there I did ctrl-M to get a command prompt (thanks to your incredibly useful StEx).

As you can see in the attached screenshot, the folder is *not* showing the proper TSVN shell commands. I have to “click” to the root SVN CO folder (C:\WORKDOCS\DOCS_jaravj\PROJ\SVN_CO_Tort) to get the proper behavior… Sometimes though it’s enough to get “up” one or two levels to get the proper behavior working…

Hope this helps.

Best Regards

                Javier

On 23.11.2011 17:37, javier dot jarava at rsa dot com wrote:
> Hi, Stefan.
>
> My user is part of the Administrators group, so I do have full access to
> the folder.

No, you don't necessarily. Vista introduced reduced access for Admins
and the UAC dialogs.

> In any case, if it was some kind of permissions issue, why would things
> change just by “climbing” up and down the checkout folder tree?
>
> I’ve attached a screen capture to show what I mean…

Repeating myself:
Please get the procmon tool from here:
http://technet.micro%e2%80%8b%e2%80%8bsoft.com/en-us/sysi%e2%80%8bn%e2%80%8bternals/bb896645<http://technet.micro%E2%80%8Bsoft.com/en-us/sysin%E2%80%8Bternals/bb896645>
and filter for 'svn.exe' and then try to repeat the problem with the CL
client.
Maybe the log shows something like access problems which might give a
hint what could be wrong here.

A video doesn't help at all.

Stefan

--
        ___
   oo // \\ "De Chelonian Mobile"
  (_,\/ \_/ \ TortoiseSVN
    \ \_/_\_/> The coolest Interface to (Sub)Version Control
    /_/ \_\ http://tortoisesvn.net
[JJarava]
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2886638
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

TSVN_CLI_Error-Capture-Folder-view-25-11-2011 9-18-26.png
Received on 2011-11-25 09:24:33 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.