[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.7.1 repo browser exception when typing invalid url parameter

From: Kan <caikanxp_at_gmail.com>
Date: Wed, 09 Nov 2011 12:43:55 +0800

I typed an invalid parameter, e.g. "http://myrepo/trunk?a", then get
this exception.
In old versions, the invalid parameters will be ignored. But in 1.7.1,
the repo browser shows an exception window.

The exception message is:

---------------------------
Subversion Exception!
---------------------------
Subversion encountered a serious problem.
Please take the time to report this on the Subversion mailing list
with as much information as possible about what
you were trying to do.
But please first search the mailing list archives for the error message
to avoid reporting the same problem repeatedly.
You can find the mailing list archives at
http://subversion.apache.org/mailing-lists.html

Subversion reported the following
(you can copy the content of this dialog
to the clipboard using Ctrl-C):

File
   “D:\Development\SVN\Releases\TortoiseSVN-1.7.1\ext\subversion
\subversion\libsvn_wc\wc_db.c”,
Line 6700:Assertion failure(svn_dirent_is_absolute(local_abspath))
---------------------------
OK
---------------------------

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2876488

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

tsvn171bug1.png
Received on 2011-11-09 10:50:18 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.