[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Re: TortoiseSVN with TortoiseHg

From: Mark Mikofski <bwanamarko_at_yahoo.com>
Date: Thu, 3 Nov 2011 16:42:48 -0700 (PDT)

Thanks for your quick reply!

Is the bug also for XP SP3? I am running XP SP3, not Win7, so I don't think your response applies to me. The context menus look the same with and without THG.

I figured out how to hide the THG context menus for non Hg folders, that helps since I mostly use TSVN.

I didn't actually think it was a TSVN bug, but since THG is fine by itself, and it's only after installing TSVN that the context menu icons get pushed off the page, I thought I should alert you. I also have posted on the THG bitbucket issue page, but I haven't heard anything from them. Perhaps you could use your influence?

Thanks again! Everyday I am learning something new about TSVN that makes me appreciate it more.

p.s. I am also currently working on a plug-in for a web-hosted issue tracker. I will screen it with you before it goes live.

- Mark

> On 03.11.2011 19:56, Mark Mikofski wrote:
> > This is my first post, so first of all I would like to express my sincere gratitude to the TortoiseSVN developers. Thank you!
> >
> > I have TortoiseHg 2.1.4 and TortoiseSVN 1.7.1 both installed on windows XP SP3, and they are both working functionally, but there is a problem with the explorer shell sub context menu icons.
> >
> > If I only install TortoiseHg the context menu icons for TortoiseHg display correctly.
> >
> > If I install both, in any order, then the top level of context menu icons for TortoiseHg are shifted to the left so that they are barely visible. The context menu icons for TortoiseSVN display correctly.
> >
> > I have posted this on the bitbucket page for TortoiseHg:
> > https://bitbucket.org/tortoisehg/thg/issue/1364/context-menus-icons-do-not-display
> >
> > I saw this once in a previous version of TortoiseSVN, and found this related post here:
> > http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=48593
> >
> > Evidently there was also a similar conflict between TortoiseGit and TortoiseSVN reported here:
> > http://code.google.com/p/tortoisegit/issues/detail?id=916
> >
> > I tried to change the ContextMenuVersion value from 2 to 1 in HKCU/Software/TortoiseHg but that caused my computer to hang on start-up after login and the initial windows xp start-up screen, and so I reverted. Honestly, I had no idea what I was doing, I just read something similar in another post.
> >
> > In all other ways both seem to be operated fine, it's just the TortoiseHg context menu icons that are affected.
>
> It's a bug in THg, but I thought it was already fixed?
> Maybe it's only fixed in the beta? Not sure though...
>
> The problem is that THg doesn't do the context menu icons correctly on
> Win7, so Windows reverts back to the old format (try it yourself: make a
> screenshot of the context menu without THg menus at all, then one with
> those menus and compare the screenshots).
>
> Stefan
>
> --
> ___
> oo // \\ "De Chelonian Mobile"
> (_,\/ \_/ \ TortoiseSVN
> \ \_/_\_/> The coolest Interface to (Sub)Version Control
> /_/ \_\ http://tortoisesvn.net

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2872575

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-11-04 02:40:34 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.